EU1 - Bartender Portal Browser Timeout Issue

Incident Report for BarTender Cloud Status Page

Postmortem

RCA #166 Summary

BarTender Cloud web-based applications were temporarily unavailable in EU1 cluster due to a certificate validation issue. This impacted authentication with inbound web application traffic, temporarily blocking web application access.

Upon identifying the root cause, we manually rotated the certificates to restore communication between all cluster nodes. Once the main components were reestablished, we validated platform functionality, confirming full recovery.

In order to prevent this type of incident in the future we are accelerating our infrastructure scalability plans for migration to Amazon EKS container orchestration layer, as well as implementing Amazon EKS automated certificate management services.

Posted Mar 14, 2025 - 09:47 PDT

Resolved

This incident has been resolved.
Posted Mar 12, 2025 - 17:35 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2025 - 17:16 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 12, 2025 - 17:04 PDT

Update

We are continuing to investigate this issue.
Posted Mar 12, 2025 - 17:04 PDT

Update

We are continuing to investigate this issue.
Posted Mar 12, 2025 - 16:08 PDT

Investigating

We have identified intermittent slow responses when loading the Bartender Portal in the EU Cluster. API endpoints remain available. Our team is actively investigating the issue.
Posted Mar 12, 2025 - 15:38 PDT
This incident affected: EU1 - BarTender Cloud (EU1 - BarTender Cloud Web Portal).