AM1 - Printing Error

Incident Report for BarTender Cloud Status Page

Postmortem

Root Cause Analysis (RCA)

Incident: AM1 – Printing Error

Date & Time

  • Monday, Jan 12: 13:50 – 14:38 PST

Incident Summary

On Monday, January 12, AM1 experienced a printing error that impacted printing functionality for a short period. The issue was isolated to a specific service and did not result in data loss.

Root Cause

The issue was caused by a disk space limitation within Kubernetes for Windows containers, where a soft limit of 20 GB was reached during normal operation. 

As disk usage increased, temporary files and unused assets accumulated within the affected containers, which led to degraded performance and printing failures.

There is an underlying infrastructure configuration that limited the disk space available to the service. As normal operational data accumulated, the service was unable to write additional data to disk, resulting in degraded performance and temporary service failures.

Detection & Diagnosis

The team observed printing failures in AM1 and identified elevated disk usage within the affected btxmlexecutor containers. Further investigation confirmed that the container-level disk limit had been reached.

Corrective Actions

  • Removed unused fonts and temporary files from the affected containers
  • Disk usage returned to safe levels and printing functionality was restored
  • The issue was fully contained following cleanup 

Resolution Status

The issue has been resolved, and printing in AM1 is operating normally.

The system remains stable under monitoring.

Preventative Actions

  • Implement production monitoring of container file system usage in the short to mid term
  • Proceed with modernization of print services, separating stateful data from stateless microservice containers, to prevent similar issues in the future 

Final Notes

  • No data loss occurred
  • The issue was isolated and short-lived
  • Longer-term architectural improvements are planned to reduce recurrence risk
Posted Jan 16, 2026 - 08:21 PST

Resolved

The issue affecting printing via in AM1 has been resolved. Printing is now operating normally.
Posted Jan 12, 2026 - 15:00 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2026 - 14:38 PST

Update

The fix has been implemented and the issue is no longer occurring. We are currently in monitoring and closely observing the system to ensure printing in AM1 continues to operate as expected.
Posted Jan 12, 2026 - 14:38 PST

Identified

The issue affecting printing in AM1 has been identified. The team is actively working on mitigation and a fix.

We will provide further updates as progress continues.
Posted Jan 12, 2026 - 14:14 PST

Investigating

We are currently experiencing an issue when attempting to print in AM1. Printing requests may fail or behave unexpectedly.

Our team is actively investigating the issue and working to identify the root cause. More information will be shared as it becomes available.
Posted Jan 12, 2026 - 13:50 PST
This incident affected: AM1 - BarTender Cloud (AM1 - Print Console).