The Print Portal is back to normal, and we’re no longer seeing delays. We’ll continue monitoring closely.
Posted Feb 25, 2026 - 12:20 PST
Update
Printing via the API is back to normal. The team is continuing to closely monitor the Print Portal to ensure stability and address any issues.
Posted Feb 25, 2026 - 11:18 PST
Update
The team is continuing to investigate the issue. Printing may be experiencing delays at this time.
Posted Feb 25, 2026 - 10:19 PST
Update
Printing via the Print Portal and API is currently impacted. Our team is working to contain the issue and restore normal operations. We’ll share another update as soon as possible.
Posted Feb 25, 2026 - 09:17 PST
Investigating
We’re seeing printing performance via Print Portal impacted again. The team is actively working to contain the issue and restore normal operation. We’ll provide another update as soon as we have more information.