EU1 - Temporary Print Gateway Disconnections due to Load Balancing Issue

Incident Report for BarTender Cloud Status Page

Postmortem

EU1 - Print Gateway Disconnections
Date and Time: June 5, 23:00 PDT – June 6, 01:13 PDT
Status: RESOLVED

Summary
During the above window, some users in the EU1 region experienced temporary disconnections when using the Print Gateway. This was due to an issue with the load balancing configuration that caused brief instability in handling gateway session traffic.

What Happened
A misconfiguration in the load balancer caused certain Print Gateway sessions to be incorrectly routed, leading to intermittent disconnections for a subset of users.

Resolution
Our engineering team quickly identified the root cause and updated the load balancing settings. The system stabilized immediately after the fix was applied, and all Print Gateway services have been operating normally since.

Next Steps
We are reviewing our deployment validation process to prevent similar misconfigurations in the future and have added enhanced monitoring to detect this type of behavior earlier.

We appreciate your patience and understanding while we worked to resolve this issue.

Posted Jun 06, 2025 - 13:35 PDT

Resolved

We experienced a brief period of intermittent disconnections affecting some Print Gateway sessions in the EU1 region. The issue was traced to a load balancing configuration that caused instability in certain sessions.

The root cause was quickly identified, and corrective actions were implemented to restore full service. All systems are now stable, and no further disruptions have been observed.

We apologize for any inconvenience this may have caused and continue to monitor the system to ensure consistent performance.
Posted Jun 05, 2025 - 23:00 PDT