Reported AM1 Printing Degradation

Incident Report for BarTender Cloud Status Page

Postmortem

Root Cause Analysis (RCA) 

Incident: AM1 – Printing Degradation
Date: Saturday, August 15, 2026
Duration: 9:53 AM – 10:26 AM PDT

Summary

Some customers in the AM1 environment experienced degraded printing performance, including delays and timeout errors when submitting print jobs. Normal printing performance was restored after approximately 33 minutes.

Root Cause

An exceptionally large and complex print request caused one of the print processing services to become unresponsive. Automated recovery attempts for the stalled process consumed a significant portion of the shared processing capacity used for print jobs.

As available capacity became constrained, other print requests using the same infrastructure experienced temporary delays and timeout errors.

Containment Actions

Our engineering team stopped the stalled print job, restarted the affected print processing service, and cleared related queued requests to prevent them from being processed again. 

These actions released the affected resources and restored normal printing performance.

Corrective Actions

The label template associated with the large print request was temporarily reverted to a previously stable version while its design and performance were reviewed.

We also worked with the affected customer to process large-volume print requests in smaller batches while permanent improvements are being implemented. 

Preventive Actions

We are implementing several improvements to increase printing resilience and prevent individual high-volume jobs from affecting other workloads:

  • Introduce limits for exceptionally large print submissions and process larger requests in smaller batches.
  • Further isolate high-volume print workloads from standard, on-demand printing.
  • Improve health-check behavior to better distinguish temporary resource spikes from service failures.
  • Enhance monitoring to detect stalled print processes earlier and enable faster recovery.
  • Evaluate additional architectural improvements to further isolate customer-facing services from underlying print processing components.

These improvements are intended to ensure that unusually large or complex print jobs can be handled without affecting printing performance for other customers.

Posted Aug 18, 2026 - 09:44 PDT

Resolved

This incident has been resolved.
Posted Aug 15, 2026 - 10:41 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 15, 2026 - 10:26 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 15, 2026 - 10:21 PDT

Investigating

We are currently investigating this issue.
Posted Aug 15, 2026 - 09:53 PDT
This incident affected: AM1 - BarTender Cloud (AM1 - Print Engine Services).