AM1 - Print portal issue

Incident Report for BarTender Cloud Status Page

Postmortem

INCIDENT RCA
AM1 – Print Portal Issues
Fri, April 10, 2026

Time: 6:51 to 7:35 PDT
Severity: Partial Outage

Summary
On April 10 between 6:51 AM and 7:35 AM PDT, some users experienced issues when trying to print through the Print Portal. The API remained available.

Root Cause
As part of our latest release, we introduced a new internal component that helps manage communication with our print processing services.

During the incident time, platform usage was higher than expected. Under this increased demand, the component reached its limit for handling multiple requests at once, which impacted the Print Portal’s ability to process print jobs.

This issue was not immediately visible in our monitoring systems because the component continued to appear healthy and did not generate clear warning signals during testing or normal operation.

Corrective Actions
We implemented a fix by increasing the capacity of the affected component, allowing it to handle a significantly higher number of requests at the same time.

After this change, the Print Portal returned to normal operation, and system stability was restored.

Preventive Actions
To reduce the risk of similar issues in the future, we have:

  • Improved our capacity planning to better account for higher usage scenarios
  • Enhanced stress testing to simulate real-world demand more accurately
  • Added deeper monitoring to detect performance limits earlier

These improvements will help ensure a more reliable experience as platform usage continues to grow.

Posted Apr 13, 2026 - 19:29 PDT

Resolved

The system is stable and the issue affecting the Print Portal has been fully resolved. All services are operating normally.
Thank you for your patience while we addressed this issue.
Posted Apr 10, 2026 - 07:50 PDT

Monitoring

A fix has been implemented and the issue affecting the Print Portal has been resolved. Printing functionality is now operating normally.

We are currently monitoring the platform to ensure continued stability.
Posted Apr 10, 2026 - 07:35 PDT

Investigating

We are currently experiencing an issue with the Print Portal, where users may be unable to print. The API remains fully operational and is not affected.

Our team is actively investigating, and we will provide updates as more information becomes available.
Posted Apr 10, 2026 - 06:51 PDT
This incident affected: AM1 - BarTender Cloud (AM1 - Print Console).