AM1 Printing Slowness

Incident Report for BarTender Cloud Status Page

Postmortem

Postmortem: AM1 Printing Slowness
Date: April 21, 2025
Time: 10:30 AM – 12:54 PM PDT (1:30 PM – 3:54 PM EDT)
Status: Resolved

Summary:
On April 21 at approximately 10:30 AM PDT (1:30 PM EDT), we began receiving reports of slowness affecting printing services in the AM1 region. Our engineering team immediately began investigating and worked to stabilize the service.

What Happened:
The issue was caused by an unexpected spike in system load, which impacted the performance of printing services. This resulted in delays and failed print attempts for some users.

This issue occurred independently of any recent infrastructure maintenance activities.

Resolution:
Service was fully restored by 12:54 PM PDT (3:54 PM EDT) after restarting key components and allocating additional resources to better handle the load.

Next Steps:
We are currently in hypercare and closely monitoring the platform. As part of this effort, we will be implementing infrastructure improvements to prevent similar issues in the future, along with enhancing monitoring and alerting capabilities.

We appreciate your patience and understanding, and we apologize for any inconvenience caused.

Posted Apr 22, 2025 - 08:59 PDT

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 12:59 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2025 - 12:54 PDT

Update

We are continuing to investigate this issue.
Posted Apr 21, 2025 - 12:40 PDT

Investigating

We are currently investigating reports of slowness affecting printing operations in the AM1 region. Our team is working to identify the cause and will provide updates as soon as possible.

Thank you for your patience.
Posted Apr 21, 2025 - 11:32 PDT
This incident affected: AM1 - BarTender Cloud (AM1 - BarTender Cloud Web Portal).