EU1 - Printing Slowness via API

Incident Report for BarTender Cloud Status Page

Postmortem

Postmortem: EU1 – Printing Slowness via API
Date: May 7, 2025
Time: 2:54 PM – 6:03 PM PDT
Status: Resolved

Summary:
On May 7, some customers using the API in the EU1 environment experienced delays and failures when attempting to print. The Web Portal was unaffected and remained fully operational during the incident. Our team investigated and restored service by 6:03 PM PDT.

What Happened:
An unexpected spike in traffic to our printing API created a large backlog of print jobs that couldn’t be processed in a timely manner. This backlog affected performance for customers using the API, resulting in slower responses and timeouts. To recover, we increased processing capacity.
 
Resolution:
Service was fully restored by 6:03 PM PDT after increasing processing capacity to handle the backlog.

Next Steps:
We are making several improvements to prevent similar issues in the future, including:

  • Strengthening API request validation and implementing traffic smoothing to prevent system overload.
  • Enhancing monitoring and alerts to detect unusual activity earlier.
  • Introduction of a job timeout mechanism to prevent stuck jobs from blocking the entire queue.

 
We appreciate your patience during this incident and remain committed to delivering reliable service.

Posted May 09, 2025 - 16:15 PDT

Resolved

The issue causing printing slowness via API in the EU1 environment has been resolved. All services are operating normally. Thank you for your patience.
Posted May 07, 2025 - 18:03 PDT

Monitoring

We are currently monitoring the printing slowness via API affecting the EU1 environment. While this issue remains under observation, we will proceed with the scheduled release as planned in 25 minutes. Our team is closely monitoring both the incident and the deployment to ensure system stability and will provide further updates as needed.
Posted May 07, 2025 - 16:05 PDT

Investigating

We are currently investigating reports of slow response times when printing through the API. Our engineering team is actively working to identify the cause and will provide updates as more information becomes available.
Posted May 07, 2025 - 14:54 PDT
This incident affected: EU1 - BarTender Cloud (EU1 - BarTender Cloud Web Portal).